December 19, 2010: 7:12 pm
Sometimes FireFox crashes. I don't know why this happens and I meant it "constantly" I am so confused about it. Can you guys help me out?
November 25, 2010: 11:54 pm
I was looking for some ways to get me better updated on firefox browser. But for some reasons I quit using firefox for it constantly crash. I use Google Chrome and am very much satisfied with it.
November 3, 2010: 4:19 pm
Very good submit. Thank for sharing. , This website is the most significant web site.
October 22, 2010: 2:23 pm
Thank you admin nice blog pages.
September 28, 2010: 3:26 pm
very good thanks you admin , really very nice article and good site
September 1, 2010: 6:36 pm
I hope getting out of Ocracoke was not necessarily needed and Earl juststays out at sea. Let us pray for that.

August 20, 2010: 11:43 am
Helpful blog, bookmarked the blog in interest to read more!
August 17, 2010: 4:02 pm
Excellent post, bookmarked the site in interest to see more!

August 12, 2010: 3:52 pm
Great blog, bookmarked your blog for interest to read more!
August 7, 2010: 2:07 am
It is a nice little extension which simply displays a play button instead of Flash ads. If you wish, you can play the Flash content by clicking on the play button.
August 6, 2010: 8:24 pm
Thank you very much for posting a lot of this excellent info! I am looking forward to seeintg more posts.
July 14, 2010: 3:31 pm
Do not cash to buy a car? Worry no more, because that is possible to take the credit loans to solve all the problems. So take a student loan to buy all you require.

June 23, 2010: 6:42 am
I used to have Firefox hogging the CPU within a few hours after starting it, however I soon realized the culprit is Facebook. Apparently the JavaScript on Facebook hogs Firefox for some reason. I resolved this by blocking scripts on Facebook, which unfortunately makes the site unusable, so I now use Chrome or IE to access it, and keep using Firefox for the rest of the sites. I can have literally hundreds of open tabs on Firefox with only 3% CPU usage at most, as long as no Facebook Java scripts are running.

June 12, 2010: 4:38 pm
Well I'm running Windows 7 64-bit with 4GB of RAM on a dual core Pentium and Firefox is still crap on this. It's okay until I leave the PC to do something else and let it go to sleep. After I wake it up it's a 50% hog. It's worse than Internet Explorer! The developers are hopeless and lazy about dealing with this and I'm close to giving up on it and trying something else. Opera used to be good but now it's just been wrecked by the geeks and not as straightforward as it used to be, Avant looks like IE in a different disguise, Chrome is okay but it doesn't save tabs. So... I don't know.
May 20, 2010: 12:39 am
I experienced the same problem on an E6800, 4gb DDR2 mem, Xubuntu 10.4. I tried out the google Touchgraph java applet; after closing it, and for about 5 minutes until I figured out that's what it was, firefox+java absolutely hammered both cores. The solution was just to kill Firefox. Now with Chrome supporting extensions, it's starting to become feasible to just use something else, such as Chrome, over Firefox. Anyway, java was definitely the culprit for me.

May 11, 2010: 10:07 am
thanks for the tips, I would also like to add that disabling AVG addons descreased Firefox's CPU usage dramatically! Fireforx went from 44% CPU usage to 0~1%!

April 27, 2010: 10:04 pm
THANK...YOU.... this was pissin me off, simple solution. Works perfect.

April 19, 2010: 11:58 am
Flashblock requires java to work, right? So doesn't step 2 wipe out step 1?

April 3, 2010: 9:50 pm
many thanks for your post. this has been getting at me for a few weeks now.

March 18, 2010: 10:31 am
Another way is to uninstall the crappy thing.

March 16, 2010: 10:08 pm
I had same problems with CPU running at 100% with or without internet. Action: Fan keep CPU cool was plugged. Open up computer (while power was off) and cleaned out build up of dusk all over the fins of cooling fan covering CPU. Now CPU is running from 3-20 %. May go up to 100% just for one second.

Sprightly jarmis
March 16, 2010: 5:35 pm
I think some of you people need to get out more. The guy is just offering a suggestion that worked for him, stop complaining if you don't want to use it - don't. Ultimately there is so much guesswork with FF (much as I love it and use it on all machines and OS's) is because there are so many incremental changes that render toolbars, add-ons and extensions incompatible or troublesome. Its difficult to tell what the underlying problem is because it might not be same on version x.x.x.x.1 as it is on version x.x.x.x.2.1. The Mozilla guys are superstars but they have proved their point, now please release fewer and more stable properly tested versions guys.
February 11, 2010: 9:34 pm
Different fields of life take a lot of time and money, thus why must we waste free time for sample essay creating? That is easier to utilize some famous essay writing service to purchase the argument essay from, I opine.

January 30, 2010: 9:47 pm
Lol - so your solution to flash players hogging the CPU is to *not* view flash video? That's hardly a solution.

January 22, 2010: 5:04 am
Switch to Chromium: Using the same version of flash (10.0r42) in both Firefox and Chromium in Ubuntu, Chromium outperforms Firefox on all flash sites I have tested. And not just by a small margin. I have a lowly AthlonXP 2400+ and Firefox uses 100% on all flash enabled sites whereas Chromium has a brief burst of high CPU use then it goes back to normal - this makes all sites usable again for me.

November 14, 2009: 11:31 pm
None of these solutions work. Aren't we all tired of guesses from people who think they know everything about computers? Everytime we have a computer issue we have to wade through a thousand different sites with guesses from self proclaimed computer experts. If you haven't personally duplicated and fixed this exact problem on several machines than shut up. We don't want to waste our time trying a million things hoping one will work. Only offer a solution if you are sure it will work. We don't care if you say "Well this works for me!". Obviously you have a different problem than the rest of us because this issue is still happening. Your advice didn't help. The Intertubes are littered with this kind of pseudo-computer-guesswork and we are all tired of reading it all and wasting our time. Flash still uses 100% CPU cycles after all of these guesses were tried.

October 14, 2009: 10:08 pm
better solution is deleting any file starting by the name firefox in c:/windows/prefetch it reduces your FF usage by 20-30%...

October 14, 2009: 10:04 pm
this is not realy a soluction... disabling flash? desabling javascript? why not just start browse in text mode?

October 10, 2009: 8:32 pm
I am getting the same exact problem with version 3.5.3. and I thought Firefox was going to take care of it!
October 9, 2009: 1:05 pm
how to fix firefox 100% CPU usage / flash player enable Flash hardware acceleration 1.type about:config in firefox browser.cache.memory 3. change it from true to false 4. restart firefox. take care Palo.

September 24, 2009: 7:31 am
Thanks a lot!! Everytime I switched to Gmail tab on Firefox 3.5.3 the memory and CPU consumption were very big (around 99% CPU usage!!). I also have MS Windows 2000, SP4 and all your recommendations worked fine..... Best regards.
August 3, 2009: 9:33 am
why site as comeing Reported Attack Site! in mozilla

The Guy who always has problems
July 29, 2009: 11:17 am
ughhh i managed to get rid of my antivirus taking up to 50 cpu usage but these stupid WINDOWS:svchosts are each taking 30 or 20 cpu each and flashblock didnt work stupid cpu usage thingie i only want to play call of duty 4:modern warfare and one more thing whats oGfOeElv it says its hl.exe i recently downloaded lots of pirated steam versions of counter-strike 1.6 plz help it would mean alot thx..
July 23, 2009: 2:15 pm
Thanks, it work for me
July 22, 2009: 8:17 pm
I turned off the javascript and my I am getting the same thing, high CPU usage. I also noticed that the system fan goes off on my HP laptop and overheats it.

July 20, 2009: 10:42 am
Turned out to be the googleupdate and googleupdater plugins for me. After I disabled those two, my cpu usage went to 0 and it freed up about 130MB of mem. Go figure.

May 15, 2009: 1:01 pm
Great help!!!! Many thanks

May 2, 2009: 8:50 pm
The fact that he's using "2 GHZ" of RAM is all I need to know.

March 4, 2009: 9:05 pm
Your "solution" is about as helpful as telling users to uninstall Firefox. Thanks for nothing.

February 21, 2009: 6:12 pm
Thanks LotharLoo for: "The only solution that I found was to disable the flash plugin at Tools > add-ons > plusins. In fact, as soon as I disabled it (which took a while for FF to respond) the CPU usage dropped to normal ~2%." I just did what you suggested and it worked ! I have 2 windows open, 8 tabs on one and 3 tabs on another window. CPU was at 99% for Firefox. I did what you suggested and a couple minutes later, CPU dropped to 2% for Firefox. Thanks.

February 17, 2009: 2:29 am
Caramba! Quase que tive um ataque quando cheguei a este site! Será que o pessoal que aqui anda não sabe escrever? Alguns exemplos: "Estou a codificação htmls alguns lotes, e eu também jogar jogos de flash a web" ; "java: você não usar java no seu navegador? applets/VPN, etc ? applets / VPN, etc? If java was not needed, how did enabling java make things slow ? Se java não era necessária, como fez java permitindo que as coisas lento?" Caramba, aprendam a escrever, por favor! P/S: Não quero com o meu singelo cometário insultar ou ofender ninguém. Apenas a quantidade de atropelos à língua Portuguesa é tal, que tinha mesmo que dizer algo, ainda que eu próprio não estou de modo algum isento de falhar muitas vezes nesse aspecto, mas espero que nunca falhe assim tanto. Cumprimentos.
February 6, 2009: 6:56 am
wow, this was killing me trying to figure why my pc became so sloooooooooooooooooooooow. I would have never thought so much flash is now being used. Thanks a million. for the help!

January 28, 2009: 11:23 am
Hi all, I had a similar problem with firefox. I've a Fedora core 10, everything updated, firefox 3.0.5 and still had the CPU problem, specially with gmail. The only solution that I found was to disable the flash plugin at Tools > add-ons > plusins. In fact, as soon as I disabled it (which took a while for FF to respond) the CPU usage dropped to normal ~2%.
January 9, 2009: 9:07 am
Many people are mentioning Gmail as the culprit, however that is a totally different issue as originally discussed here...causing nothing but confusion. It may have solved a Gmail usage related issue, however it has nothing to do with the original issue which everyone is facing. I have Firefox installed on 6 different machines & environments i.e. on XP and Server 2003 OSs, with different RAM and Processor configurations, enabled and disabled extensions, flash blockers etc. but nothing seems to be working. When I make any changes, it does seem faster (or atleast I think it feels faster) but then at some point or the other Firefox eventually take control of the CPU and doesn't let go unless I close it :/
December 23, 2008: 3:31 pm
Uninstalling my old firewall (outpost) solved the problem for me. Just disabling the firewall didn't solved anything. Now I use Comodo and everything works great. I hope this helps.

October 7, 2008: 5:12 pm
try to update both players: Adobe Flash Player from here: Adobe Shockwave Player from here: this updates solved my 100% cpu usage problem. please post a comment at here if this solve your problem too. thx -.-

October 6, 2008: 6:35 pm
OR just nav to C:/Documents and Settings/Your Username/Local Settings/Application Data/Mozilla/Firefox/Profiles/dbrv58vc.ProfileName (whatever it is called) Delete the two files in there beginning with an "x". Restart firefox. Firefox will regenerate these files. I, like you all tried every solution under the sun for this for about 2-3 months! NOTHING worked. about 5-15 solutions I tried to no avail. This did the trick though this information was hard to find!
September 29, 2008: 11:52 pm
Disable the DOM Inspector - I found that in complex website, it was going 100% cpu while not doing anything else, once i disabled that add-on, back to %2 :))

June 13, 2008: 11:43 am
Gmail was the culprit for me. Who'd have thought it would be them that would crap out a browser. I haven't installed anything fancy but just switched to the Older Version of GMail. Worked a treat.

June 3, 2008: 2:18 pm
Try renaming the folder C:\Documents and Settings\\Application Data\mozila to something else . then when you start firefox it will ask you to import the settings again. you can then copy the bookmarks etc from the renamed folder to the new folder that firefox created. That solved my problem. it runs perfectly now
March 25, 2008: 1:02 pm
dude i have an amd 64 X2 6400+ 2 Gigs of DDR22 800 and integrated video AMD 690G based on a Ati radeon 1250 on a gigabyte motherboard and i have not that kind of problem, you may have this problem when entering to sites like megaupload that have nearly 14 flash elements or more, the thing here is that AMD is better in that way because of 3dnow professional that is in every AMD processor, i love firefox and right now i am helping as a volunteer to test firefox 3 beta 4, i think is the best navigator ever done. i don´t try to bother you, intel have a lot of good things but in Graphics and Multimedia i think AMD is better. Best regards Jose Diaz Everyone Please Help Firefox today, Try the Firefox 3 Beta 4!
March 21, 2008: 8:11 pm
Just disable or uninstall all add-ons.

March 10, 2008: 10:38 am
David B. Says: March 9th, 2008 at 1:32 pm I had loads of issues with Firefox using up close to 100% CPU, and tried a few different things. Anyway, I finally figured out - that for me at least - all I needed to do was to switch Gmail to use the “Older Version.” I always have Gmail open, and there’s a link in the top-right of th
Yes thats it i did this before but forgot this is the solution. Thank you.

David B.
March 9, 2008: 1:32 pm
I had loads of issues with Firefox using up close to 100% CPU, and tried a few different things. Anyway, I finally figured out - that for me at least - all I needed to do was to switch Gmail to use the "Older Version." I always have Gmail open, and there's a link in the top-right of the Gmail window which says "Newer Version" or "Older Version" (according to which one you're using at the time). It's not the non-JavaScript version, just a previous incarnation of the JavaScript version, and so it still has all the bells and whistles. Anyway, hope that helps someone! It worked for me.
February 24, 2008: 4:36 am
Another solution? Use Opera :)
February 23, 2008: 12:41 pm
I am using adblock and noscript extensions, but I will not disable the flash, java and javascript content. I am coding some htmls and I also play lots of flash games over the web, so the flash block is not a solution. The flash content is not the problem, the problem is the flash update or some coding of it. From the Macromedia\'a takeover by the Adobe, all the flash content was screwed. I didn\'t have the flash 100%cpu problem since last week, so it must be a wrong update from the flashplayer or firefox. For a typewriter or work computer, the blocking of the annoying content is the solution, but for the everyday guy who is surfing and playing and coding something, this cannot be. Another solution is required and I\'m looking every day for it.

December 30, 2007: 7:48 am
It\'s not just flash and java. Firefox also has a problem with some JavaScript. See this bug (and please vote for it).
December 20, 2007: 2:25 pm
wow - thanks for the heads up. I'll have to try this.

October 6, 2007: 10:00 pm
I find Firefox uses 99%-100% of CPU time even when I only have two windows open: Firefox and the Downloads windows (downloading 4 files). I disabled Java but did nothing to alleviate my problem. Still looking to find a solution. It was never a problem when I used Flashget but for some reason I cant get it to work with Firefox anymore.
August 1, 2007: 3:57 pm
I'm developing a web site using Java and Flash.... I think this information could be useful... but it isn't... Another ideas rather than disabling features on my firefox? Something like limiting the amount of processor time?

June 7, 2007: 1:40 pm
Yo Angsuman - Thanks a million! (OK, I'll just owe it to you . . .) I have posted on Mozilla Forums several times in past 6 months and nobody came up with a solution. Currently, I have only installed FlashBlock and left Java as is, but Firefox has been very well behaved with just that one modification. This is great. Thanks again, Fredo

June 2, 2007: 11:20 pm
I *have* to have Java for certain websites, so I found this add-on to be just the ticket:
May 4, 2007: 7:11 am
Anjan, Normally I don't need Java on my browser. However for some strange reason Firefox continues to hog cpu even when Java is not used; a bug perhaps. Best, Angsuman
May 3, 2007: 11:35 am
Ahaha! Thanks man! It sucks when you've got tons of windows opened, some logged in, and that 100% crap happens.
April 30, 2007: 3:55 pm
hi there, flash : thanks for the tip. I have an old PC at home which will surely benefit from this. java : don't you use java on your browser ? applets/VPN, etc ? If java was not needed, how did enabling java make things slow ? Thank you, BR, ~A